Can't teleport in TLC - Fixed

keukeu

New Member
Hello there.

Long time lover of Fable TLC, I recently purchased it on Steam to run through it again. After some time I ran into a familiar problem I remembered having years earlier : all of a sudden I can't charge my Guild Seal, Cullis gates are off and I can't use my Guild Seal even through the menu. Can not teleport in any way.

I dug around in google and found many others had the same problem. Here's some of the stuff I tried :
  • walking back to the guild to start a new quest
  • ending a currently active new quest
  • completing the recurrent "merchant escort to the Orchard Farm" quest
Non of it worked.

I had just beaten Thunder to marry Lady Grey, next stop was Lychfield Graveyard so I decided to keep going for now.

And that's when it solved itself.

When I entered the Gibbet Woods area my Guild Seal suddently woke up. I also heard multiple lines of the Guildmaster telling me about new quests and such, as if they had queued up until now.
What I think happened is that the game glitched out after I beat Thunder and exited the Demon Door that leads back to the Gibbet Woods. The game must have an ON/OFF switch for teleporting so that the player can't teleport when on a mission. Maybe the switch didn't got back ON when I exited the demon door and revisiting the area fixed the problem.

So if you encounter this glitch try re-visiting some recent areas on foot, maybe it will fix itself out.

I hope this will be of some help. Until then keep listening to the Guildmaster, you don't wanna run out of potions.
 

Dark Drakan

Administrator
Staff member
Guildmaster
Legendary Hero
Thanks for the advice and we hope it helps anyone out that may encounter this is future.
 
Top