Fable lll loading screen

Ghost

New Member
Joined
Sep 23, 2016
Messages
2
Reaction score
0
Points
1
Age
20
I need some help with an issue. I have played fable 3 for a while and had to restart a couple times because I messed up the last mission in the main storyline. So on my third try, I'm back as king and now have a year before the darkness. I looked up if there were some fast ways to bring up the treasure. I found out there were secret rooms with treasure in the castle. So I did them and continued playing. After about a week, I went on again. I pressed start and it went to the loading screen. And it stayed on it. It didn't freeze, it just kept on loading and loading. I know that because the ring and the chicken were still moving. So I waited and waited. The screen went dark at least 5 times and I went back to Xbox home. I tried again and again, with the same result. Everyone else in my family is still able to play though. And when I join one of them, I'm in the starter female form. With only a nightgown and cap, a rifle and a sword. Nothing else. Is there any way I could get all my progress back and be able to play again?
 

Dark Drakan

Administrator
Staff member
Guildmaster
Legendary Hero
Joined
Feb 6, 2006
Messages
25,510
Reaction score
2,266
Points
365
Age
34
Sounds to me like a corrupt save file, heard of many instances of files getting messed up and progress lost but not seen it myself. Dont know why so many instances werent patched when they have seemed so frequent.
 

cheezMcNASTY

Edible in some countries
Legendary Hero
Joined
Jan 6, 2007
Messages
6,174
Reaction score
1,634
Points
315
I think Drakan is correct.

To delete your Fable 3 saves, you'll need to navigate to xbox settings. Find your hard drive and manage storage. I don't know how this affects your family's save files so proceed with caution.

Since the corruption hits Fable 3 before you have access to the main menu, you seem to be unable to do it the usual way, unfortunately.
 
Top